Project

General

Profile

Bug #114

Character conversion for commands.conf OSD confirmation messages fails

Added by Anonymous over 12 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
04/13/2009
Due date:
% Done:

0%


Description

Hi,

I have the commands.conf file in UTF-8 encoding. The file contains lines with characters like 'ä'. When browsing the commands menu every characters in shown correctly in the LCD, but when I press "ok" on a commands menu item, the character conversion breaks and characters like 'ä' are distorted in the confirmation message that follows.

History

#1 Updated by jowi24 over 12 years ago

  • Status changed from New to Feedback

I cannot reproduce this. What is the confirmation message you describe? Does the script generate any further output?

#2 Updated by phelin over 11 years ago

  • File commands.conf added

I have done a bit more testing and found out that the conversion fails only for the first confirmation message after you enter the commands menu. If you cancel the first confirmation and select the same item again it will result in a proper confirmation message. I have attached my commands.conf file. Please note that it is in utf-8.

Here is how to reproduce:

1. Use the attached commands.conf
2. Open the commands submenu
3. Press the "ok" button on the first item.
4. VDR will ask you to confirm the selection. The message is displayed properly in VDR output, but garbled in lcdproc-plugin's output.
5. Press back to cancel.
6. Press again "ok".
7. VDR will once again ask you to confirm the selection. Now the confirmation query is shown properly in both outputs.

#3 Updated by Anonymous over 11 years ago

  • File deleted (commands.conf)

#4 Updated by jowi24 over 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF